これ僕.com:行動分析学マニアがおくる行動戦略

意図と行動のギャップから生じる「不自由さ」への挑戦。果たして僕たちに自由はあるのか?

railsを1.2にしたらgenerateできなくなった

railsのバージョンを1.2.3に変更。新しいプロジェクトを作って、"$ruby script/generate model hoge"とかやると、

undefined method `gem' for main:Object (NoMethodError)

というエラーが出た。RubyGemsのバージョンが古いのかと思いチェック。

$ gem --version
0.8.10

調べてみると、どうやら0.9.2が最新らしい。早速アップデートしてみる。

  1. ここからファイルをダウンロードして、解凍。
  2. 解凍したディレクトリに移動して、"$ sudo ruby setup.rb"を実行。

Setup完了後、再びバージョンを確認。

$ gem --version
0.9.2

で、再度script/generateを試したら上手くいった。わーい。